Connectivity issues to our west-us region

Incident Report for Hyro AI

Resolved

Incident is resolved. Once we get an RCA from Azure we will post a followup.
Posted Mar 22, 2026 - 23:36 UTC

Update

Issue seems to be currently mitigated, we have switch back traffic to both regions.
We are continuing to monitor and awaiting response from Azure support.
Posted Mar 22, 2026 - 19:12 UTC

Monitoring

The failover to east is successful. We are monitoring the situation in west, a ticket has been escalated to Azure support.
Posted Mar 22, 2026 - 17:57 UTC

Identified

At around 1:00pm EST we started noticing intermittent connection errors in our west-us region. After a quick investigation we failed over to our east region, the failover was completed at around 1:40pm.
Posted Mar 22, 2026 - 17:15 UTC
This incident affected: Chanel - Voice, Channel - Chat, Communication Service, and Core AI Services.