Voice calls dropping

Incident Report for Hyro AI

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 20:34 UTC

Monitoring

Since this morning, We have been experiencing some small percentage of dropped calls. While investigating we found that the most likely cause is an Azure service that does the load balancing for us. While trying to fail over to a single region and bypass the load balancer we accidentally caused 5m of down time between ~11:30 to 11:35, until the services were fully synced.
Since then all services have been running like normal, we are monitoring the situation
A detailed PIR with corrective actions will be shared in the next few days.
Posted Jun 18, 2026 - 03:30 UTC
This incident affected: Chanel - Voice.