Login Issues with Hyro Dashboard

Incident Report for Hyro AI

Resolved

This incident has been resolved.
Posted Dec 22, 2025 - 11:16 UTC

Investigating

We are currently investigating reports of users being unable to log in to the Hyro Dashboard. Our engineering team is looking into the root cause, and we will provide an update as soon as more information is available. We apologize for the inconvenience.
Posted Dec 22, 2025 - 11:04 UTC
This incident affected: Hyro Customers Portal.